aMule supporta (finalmente) il protocollo di offuscamento

Mi quasi vergognavo di dover utilizzare Wine solo per emulare eMule, ma d’ora in avanti non sarà più necessario: aMule ha aggiunto il protocollo di offuscamento!

 

Basta andare in Preferenze –> Sicurezza ed attivarlo. Questa funzione la troviamo nella versione CVS di aMule. Per installarlo, il nostro grande Treviño ha impacchettato tutto e lo ha caricato sul suo repository.
Per utilizzarlo, basta aprire il nostro sources.list con il comando
sudo gedit /etc/apt/sources.list
ed inserire queste due righe
deb http://download.tuxfamily.org/3v1deb feisty 3v1n0
deb-src http://download.tuxfamily.org/3v1deb feisty 3v1n0

A questo punto abbiamo bisogno della chiave, essendo un repository autenticato. Per scaricarla ed aggiungerla basta dare dal terminale
wget http://download.tuxfamily.org/3v1deb/DD800CD9.gpg -O- | sudo apt-key add -
A questo punto aggiorniamo APT con apt-get update e scarichiamo amule!
E grazie ancora a Treviño :) .

21 Risposte

  1. ci son problemi con le dipendenze…?
    nn riesco a installarlo!

  2. @ Algol: non saprei dirti, io l’ho installato tranquillamente. Che errore ti da?

  3. mi vuole installare amule dai repository normali… e nn lo prende da trevino, ovviamente ho controllato mille volte che il repo sia abilitato ed ho fatto l’update.
    tu che comando hai dato sudo apt-get install ?????

  4. edit: ho installato a mano (cioè scaricando i pacchetti dal link che hai dato tu)
    ed ho messo amule e amule-common pare funzionare…
    amule-utils tu l’hai messo?

    p.s. scusa il doppio post

  5. Bhe si in effetti se tenti di installare amule-utils c’è un problema con le dipendenze, la libfree se non erro? Comunque funziona bene anche senza quel pacchetto, nel cui ci sono utilities non proprio fondamentali secondo me poi ovviamente non conoscendo il caso specifico, insomma se per te sono importanti. Confermo anche io che non sono riuscito a installare il pacchetto per questa dipendenza non risolta.

  6. allora da questi repo ho preso libfreetype6 (2.3.5)
    deb http://www.telemail.fi/mlind/ubuntu feisty fonts
    deb-src http://www.telemail.fi/mlind/ubuntu feisty fonts

    mentre l’altro direttamente da trevino sul blog… che faticata ma va tutto
    grazie della segnalazione, l’aspettavo da tempo :D

  7. grazie a trvino come sempre , se però ci fà il favore di guardare anche noi poveracci con un dual core , gli saremo ancora di più grati…

    grazie trvi per i repository amd-64………però prossimamente anche aMule dai.
    é uno di quei software di cui non si può fare a meno..

    ciao ciao.

  8. grande, lo stavo cercando proprio oggi!

    io ho aggiornato solo i pacchetti amule e amule-common, amule-utils no, per quello stesso problema con le dipendenze. questo pacchetto serve, tra le altre cose, a caricare i link ed2k direttamente dal browser, ed è molto comodo. spero funzioni ugualmente. Qualcuno sa, invece, a cosa serve amule-utils-gui?
    salute

  9. aMule supporta (finalmente) il protocollo di offuscamento

    Mi quasi vergognavo di dover utilizzare Wine solo per emulare eMule, ma d’ora in avanti non sarà più necessario: aMule ha aggiunto il protocollo di offuscamento!

  10. Ho aggiunto i repo da synaptic ed installato amule e amule-common
    funziona perfettamente

    Grazie

  11. Ditemi quello che volete ma emule funziona cmq meglio e soprattutto…è stato risolto il bug di amule riguardante la connessione Kad?

  12. […] Fonte e installazione su Debian e simili […]

  13. Vorrei sapere anch’io se aMule su linux è in grado di supportare la rete kad come succede da sempre su wizoz. La supporta? Grazie ciao

  14. @ night2night: sì.

  15. ammetto che quando sono passato a linux la mancanza del protocollo di offuscamento in aMule è stata proprio un brutto colpo..era ora!! Treviño ottimo come sempre e ovviamente complimenti per il blog..spero che un giorno anche il mio diventi così popolare,anzi commentate:
    http://emilator.wordpress.com/

  16. Perfetto! Grazie!! Uno dei motivi che mi frenava a cambiare da winzozz a linux era la piena funzionalità del mulo. Adesso anche questo freno è tolto linux si avvicina di mooooolto ;) grazie mille

  17. […] di avvalersi del protocollo di offuscamento. Amule ancora non lo supporta ufficialmente ma in questo provvidenziale articolo potete leggere come risolvere il problema.ATTENZIONE! Come potete leggere qui, l’offuscamento […]

  18. GRANDI perfetto!!!

    ho deciso di copiare questa guida nel mio sito per il bene comune è necessario che si diffonda!!

    aMule CVS!!!!

    grazie

  19. Ciao, bene davvero, mi sembra che le informazioni che date siano molto preziose, ho però un grosso problema di comprensione ….. maledetta ignoranza!! Qualcuno potrebbe provare a spiegarmi il procedimento di installazione della versione cvs con un linguaggio molto semplice? Se serve posso dirvi che uso Mac OS X 10.4.8 ed ho installato A-Mule 2.1.3. Ringrazio da subito chiunque abbia voglia di darmi una mano. Ciao a tutti

  20. W: GPG error: http://download.tuxfamily.org feisty Release: Le seguenti firme non sono state verificate perché la chiave pubblica non è disponibile: NO_PUBKEY 2D6CFB44DD800CD9

    A cosa è dovuto?

Lascia un commento

Inserisci i tuoi dati qui sotto o clicca su un'icona per effettuare l'accesso:

Logo WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione / Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione / Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione / Modifica )

Google+ photo

Stai commentando usando il tuo account Google+. Chiudi sessione / Modifica )

Connessione a %s...

%d blogger cliccano Mi Piace per questo: